TUTORIAL How to install Multicraft on Dedictated Servers

Discussion in 'Community Knowledgebase' started by ChrisC, Feb 12, 2016.

  1. ChrisC

    ChrisC Forum Moderator
    Moderator

    Joined:
    Jul 7, 2015
    Messages:
    2,490
    Likes Received:
    276
    Best Answers:
    5
    This is a tutorial on how to install Multicraft on a McProhosting Dedicated servers. These tutorials cover Ubuntu, CentOS 7, Debian. I have decided to make this as i have installed many of Multicraft panels onto Dedicated servers i the past including 3 of my own and thought i might share this knowledge to all.

    At the moment Ubuntu is the Only Tutorial i have finished. I will be continuing to update these over time.

    When Purchasing a Dedicated Server, You will received by Email you Login/Password and instuctions how to login to your server over SSH with PuTTy.

    Once you have your OS on the server and have connection via PuTTy you can continue to follow these instructions to install www.multicraft.org Server panel on your Dedicated server. But please beware that using a Dedicated server is "Mid" knowledge of understanding of Linux Os and how Multicraft works to run your server and if you don't i recommend using our Shared Plans. Over time you will develop a skill of understanding these 2 systems and how they work. Its a good way to learn if you have the Free Time.
    GoodLuck and enjoy the Freedom of a Dedicated Server. Happy Installing :D.

    NOTE: Every Quote starting with a # is a terminal command. Please don't include the starting # into the command.

    1) - Update System:
    2) -Install (Apache2, ZIP, UNZIP, MySQL-Server)
    1. Create a MySQL password [Enter]. Take note your Username will display in "-" Example: "root"
    2. Confirm the Password. [Enter]
    3) -Install PhpMyAdmin:
    1. You will be prompt with a Option. Press [SpaceBar] to place [*] inside Apache2 and press [Enter].
    2. Then Press [Enter] to Configure PhpmyAdmin.
    3. Create a Password for you Login and Continue.
    4. Enter your MySQL password [Enter] Then Re-Enter Password to Confirm [Enter]
    4) -Install (PHP5, and LibApache2-Mod-PHP5.):
    5) -Install Java8-JDK - Accept Terms if Prompt:
    6) -Download Multicraft:
    7) -Extract Multicraft:
    8) -Change into the extracted directory:
    9) -Run the setup.sh script:
    10) - Setup Script:
    1. y
    2. root
    3. /home/root/multicraft
    4. Enter License Key, If you have one
    5. 1
    6. y
    7. www-data
    8. [​IMG]
    9. Create a Password for the Daemon. Default: [none]
    10. y
    11. Enter you server Main IP. press [Enter] if default is correct.
    12. 21
    13. n
    14. mysql
    15. 127.0.0.1
    16. multicraft_daemon
    17. root
    18. MySQL Password you set above in Step 2:1.
    19. y
    20. press [Enter]
    21. n
    11) - Open Internet Browser and go to http://your_server_ip/Phpmyadmin
    1. Login with Username: root Password: Your created in Step 2:1 (MySQL) password.
    2. Open Tab [​IMG]
    3. Create database: multicraft_panel and multicraft_daemon - Result

    12) -Open Internet Browser and go to http://your_server_ip/html/multicraft/install.php
    Note: If this directory doesn't exist, In Terminal - (PuTTy) do command:
    Change:
    To:
    save Changes Ctrl + X then Y press [Enter]

    Then do:
    Should say: * Restarting web server apache2 [ OK ]
    13) - Continue the setup in http://your_server_ip/html/multicraft/install.php

    1. Click Start Installation.
    2. You will see Protection Directory: Failed
    1. Open Terminal-(PuTTy)
    Do command
    Change: AllowOverride None
    To: AllowOverride All
    http://puu.sh/nQOR5/31907ac0a4.png

    2. save Changes Ctrl + X then Y press [Enter]
    3. Restart Apache2

    3. Refresh Browser and Protected Directory: PASSED. -View
    4. Press Continue.
    5. Press Continue Again if Configuration File Found.
    6. Setup the Panel MySQL - View Press Save, Then Initialize Database, Then Continue.
    7. Setup the Daemon MySQL - View Press Save, Then Initialize Database, Then Continue.
    8. In Basic Configuration go to Password for daemon connections and Enter the password you created for the Daemon in Step 10:10. Default Password: none
    9. Press Save and Continue.
    10. Open Terminal - (PuTTy) and start the Daemon(s).
    11. Refresh the Detection Daemon. -View
    1. Open Terminal- (PuTTy) and do command:
    2. Verify if the multicraft.conf password match what you setup on Multicraft and make any needed Changes in multicraft.conf. To exit the Multicraft.conf do Ctrl + X then N then [Enter]

    3. After any Changes restart the Daemon.
    12. After the Daemon is Detected press Continue and Delete the Install.php:
    13. Congrats You setup Multicraft on Ubuntu 14.04 LTS.

    Apache/Unzip,Zip
    Step:1 - Install Apache2, UnZip, Zip.
    Step:2 - Start/Enable Httpd.Service
    MySQL
    Step:3 - Install Mysql-mariadb
    Step:4 - Setup Mysql
    1. [Enter]
    2. Y
    3. *Create new Password*
    4. *Confirm new Password*
    5. Y
    6. N
    7. Y
    8. Y
    PhpMyAdmin

    Step:5 - Install PhpMyAdmin
    Step:6 - Setup PhpMyAdmin
    Add # to Require ip 127.0.0.1 and Require ip ::1
    Add Require all granted.

    Change:
    [​IMG]

    To:
    [​IMG]

    Then save Changes. Ctrl + X then Y then [Enter].
    PHP/ Java 8
    Step:7 - Install Php include Modules.


    Step:8 - Restart Apache2

    Multicraft
    Step:9 - Install/Setup Multicraft
    1. y
    2. root
    3. /home/root/multicraft
    4. Enter License Key, If you have one
    5. 1
    6. y
    7. apache
    8. [​IMG]
    9. Create a Password for the Daemon. Default: [none]
    10. y
    11. Enter you server Main IP. press [Enter] if default is correct.
    12. 21
    13. n
    14. mysql
    15. 127.0.0.1
    16. [Enter]
    17. multicraft_daemon
    18. root
    19. MySQL Password you set above in Step:4 Mysql
    20. y
    21. press [Enter]
    22. n
    Replace All: AllowOverride None with AllowOverride All. (Total 4 to change)
    Then save. Ctrl + X then Y then [Enter]

    Restart Apache
    Database
    Step:10 - Create Database
    Open Internet Browser and go to http://your_server_ip/Phpmyadmin
    1. Login with Username: root Password: Your created in Step:4 (MySQL) password.
    2. Open Tab [​IMG]
    3. Create database: multicraft_panel and multicraft_daemon - Result
    Step:11 - Multicraft Install.php
    Continue the setup in http://your_server_ip/html/multicraft/install.php

    1. Press Continue.
    2. Press Continue Again if Configuration File Found.
    3. Setup the Panel MySQL - View Press Save, Then Initialize Database, ThenContinue.
    4. Login using username: admin password: admin
    5. 7. Setup the Daemon MySQL - View Press Save, Then Initialize Database, Then Continue.
    6. In Basic Configuration go to Password for daemon connections and Enter the password you created for the Daemon in Step:9-10 Default Password: none
    7. Press Save and Continue.
    8. Open Terminal - (PuTTy) and start the Daemon(s). - View
    10. Refresh the Detection Daemon. -View
    1. Open Terminal- (PuTTy) and do command:
    2. Verify if the multicraft.conf password match what you setup on Multicraft and make any needed Changes in Multicraft.conf. To exit the Multicraft.conf do Ctrl + X then N then [Enter]

    3. After any Changes restart the Daemon.
    11. After the Daemon is Detected press Continue and Delete the Install.php:
    12. Congrats You setup Multicraft on Centos 7​

    Coming Soon

    --------------------------------------------------------------------------------------------------------------------------------------------------------------
    Multicraft Dedicated Servers Knowledgebase:

    1. Open you multicraft Panel (http://YourServerIP/html/multicraft/index.php)
    2. Open Settings Tab.
    3. Open Update Minecraft in the sidebar.
    4. Select a File. (Default Minecraft Server, Craftbukkit, Craftbukkit Beta, Spigot, Optimized).
    5. Set "Type" to JAR and Config
    6. Set "Action" to Download Only
    7. Press OK
    8. When Displays "Ready to Install" set "Action" to Install.
    9. Press Ok
    1. Open you multicraft Panel (http://YourServerIP/html/multicraft/index.php)
    2. Open Settings Tab.
    3. Open Update Minecraft in the sidebar.
    4. Select a File. (Default Minecraft Server, Craftbukkit, Craftbukkit Beta, Spigot, Optimized).
    5. Set "Type" to JAR and Config
    6. Set "Action" to Update
    7. Press OK
    1. Open you multicraft Panel (http://YourServerIP/html/multicraft/index.php)
    2. Open Servers
    3. Open +Create Server
    4. Name the Server.
    5. Number Of Slots.
    6. Assign Server Owner.
    7. Set Server Port. (Default 25565. If 25565 used use 25566 or 25567 and continue.
    8. Server Memory. 512Ram or 1052Ram or more.
    9. Click Create
    10. Now view the server Created.
    11. Set JAR File to what you want to use. (Spigot, Craftbukkit, Default Minecraft Server).
    12. Set Owner Permissions if you wish.
    13. Spam the "Accept EULA" button.
    14. Save Server.
    15. Now start it.
    NOTE: Be sure you have preformed "Update/Install Server Type JAR". Failing to do so will result server won't start due the Server Jar missing.
    1. Open you multicraft Panel (http://YourServerIP/html/multicraft/index.php)
    2. Open Server Tab.
    3. Set "Jar File" to 'Default'
    4. Below Default enter the name "custom.jar" - View
    5. Click "Show Advanced Settings"
    6. Set "Look for JARs in" to Server base directory*
    7. Save Changes.
    8. Click on Advanced tab on the Sidebar and select "Users"
    9. Set your Permissions to "Full Access" and "Co-Owner"
    10. press Back and Open "FTP Files Access" in the "Files" tab in the sidebar.
    11. Enter These details into FileZilla or WebFTP
    12. Upload the "custom.jar" to the Root Directory.
    13. Done.
    1. Open you multicraft Panel (http://YourServerIP/html/multicraft/index.php)
    2. Open Settings Tab.
    3. Open Panel Configuration on the Sidebar.
    4. At the bottom set "YES" to Allow Users to Create a MySQL Database
    5. Set User DB Host: Server IP Address.
    6. Set User DB Username: root
    7. Set DB Password: MySQL Root Password.
    8. Set DB Prefix: mcph
    9. Set DB Admin Link: http://YourServerIP/phpmyadmin
    10. Save Changes and now you have the ability to go to "Advanced" and "MySQL Database" in Each server.
    1. Open Terminal-(PuTTy)
    2. press Ctrl + W and enter "Upload_max_filesize" set this to "256M"
    3. press Ctrl + W and enter "Post_max_Size" set this to "256M"
    4. press Ctrl + W and enter "default_socket_timeout" set this to "1200"
    5. press Ctrl + W and enter "memory_limitt" set this to "258M"
    6. press Ctrl + W and enter "max_execution_time" set this to "1200"
    7. press Ctrl + W and enter "max_input_time" set this to "1200"
    8. Save Changes Ctrl + X then Y then [Enter]
    9. restart apache2
    1. Open you multicraft Panel (http://YourServerIP/html/multicraft/index.php)
    2. Open Settings Tab.
    3. Open Panel Configuration on the Sidebar.
    4. Open "Show Advanced Settings"
    5. Set "Disable User Registration" to No
    6. Save Changes.
    7. Users and Register via Login Page.
    1. Connect to your Dedicayed server by Terminal-(PuTTy).
    2. You command # Sudo REBOOT
    3. after reconnecting to terminal after reboot
    4. Start Apache

    5. Start MySQL-server

    6. Start Multicraft Daemon.

    4. Start Apache2
    5. Start MySQL
    6. Start Multicraft Daemon.
     
    #1 ChrisC, Feb 12, 2016
    Last edited: Mar 23, 2016
  2. ChrisC

    ChrisC Forum Moderator
    Moderator

    Joined:
    Jul 7, 2015
    Messages:
    2,490
    Likes Received:
    276
    Best Answers:
    5
    UPDATE
    I have completed the Centos 7 and Ubuntu Multicraft installs.
    Note: When preforming the Install.php setup, I found Google Chrome Browser will show that the MySQL was connected but the database was not found. To resolved this please use Internet Explore or FireFox.

    @TylerD how do these look? Do you recommend anything that should be added?
     
  3. Clyv

    Clyv Member

    Joined:
    Sep 23, 2015
    Messages:
    237
    Likes Received:
    23
    Best Answers:
    0
    Make sure you have apache running

    Type "service apache2 start"

    sudo apt-get install apache2

    Try "yum -y install apache2"

    I'm not good with centos so err...

    Strike that.

    # yum -y install httpd
    # yum install unzip
    # yum install zip

    Check this out:

    https://www.howtoforge.com/apache_php_mysql_on_centos_7_lamp
     
    #3 Clyv, Dec 30, 2016
    Last edited by a moderator: Dec 30, 2016
  4. Cory

    Cory Head Systems Administrator
    Administrator

    Joined:
    Jul 25, 2013
    Messages:
    54
    Likes Received:
    23
    Best Answers:
    0
    Code:
    IP="$(curl -4 icanhazip.com)"; sed -i "s/\ftpIp =\(.*\)/\EftpIp = ${IP}/g" /home/root/multicraft/multicraft.conf
    
    Make sure you change /home/root/multicraft/multicraft.conf to your path of your Multicraft installation. :)
     
  5. Clyv

    Clyv Member

    Joined:
    Sep 23, 2015
    Messages:
    237
    Likes Received:
    23
    Best Answers:
    0
    @Cory is the guy behind all of MCProhosting's servers, try what he says as he is a genious.
     
  6. ChrisC

    ChrisC Forum Moderator
    Moderator

    Joined:
    Jul 7, 2015
    Messages:
    2,490
    Likes Received:
    276
    Best Answers:
    5
    Have you installed to Phpmyadmin? Try reperforming Step 5 and 6 and take note of any errors.
    You may need to remove it again to install Pypmyadmin again. Use command below to remove Phpmyadmin

     
  7. Clyv

    Clyv Member

    Joined:
    Sep 23, 2015
    Messages:
    237
    Likes Received:
    23
    Best Answers:
    0
    not ubuntu
     
  8. ChrisC

    ChrisC Forum Moderator
    Moderator

    Joined:
    Jul 7, 2015
    Messages:
    2,490
    Likes Received:
    276
    Best Answers:
    5
    This is instruction from Centos guide.
    For what I understand
    Centos7 Guide Step 10 is creating a Database with Pypmyadmin. The trouble is that he has no website directory when going to http://Your-IP/phpmyadmin.

    Example: [​IMG]
     
  9. Cory

    Cory Head Systems Administrator
    Administrator

    Joined:
    Jul 25, 2013
    Messages:
    54
    Likes Received:
    23
    Best Answers:
    0
    I wrote my own automated script. :)

    https://github.com/JustOneMoreBlock/shell-scripts

    Been using it for months and works well, just fixed a Debian issue.

    It's just a one-liner
    (Supported Versions: Ubuntu, Debian and CentOS 6 and CentOS 7)
    Code:
    yum -y install wget; apt-get -y install wget; wget https://raw.githubusercontent.com/JustOneMoreBlock/shell-scripts/master/auto-install-multicraft.sh -O auto-install-multicraft.sh; chmod +x auto-install-multicraft.sh; sh auto-install-multicraft.sh
    
    Now keep in mind, this is mainly used for fresh installs and if you already installed stuff then it may error out. :p

    @ChrisC just go look at the script, it's nice a purdy. :)
    https://github.com/JustOneMoreBlock/shell-scripts/blob/master/auto-install-multicraft.sh
     
  10. ChrisC

    ChrisC Forum Moderator
    Moderator

    Joined:
    Jul 7, 2015
    Messages:
    2,490
    Likes Received:
    276
    Best Answers:
    5
    Interesting will try it out.
    Should make all Dedicated server users installation much easier :D @Cory

    Just gonna install a OS and try it out

    EDIT: Works. Just having trouble getting to the PHPMyAdmin page.
    [​IMG]
     
  11. Cory

    Cory Head Systems Administrator
    Administrator

    Joined:
    Jul 25, 2013
    Messages:
    54
    Likes Received:
    23
    Best Answers:
    0
    @ChrisC You silly everything is case sensitive on websites. :p
     
    • Funny Funny x 2
  12. ChrisC

    ChrisC Forum Moderator
    Moderator

    Joined:
    Jul 7, 2015
    Messages:
    2,490
    Likes Received:
    276
    Best Answers:
    5
    Wasn't that. I had to reload the httpd then change the permission from 127.0.0.1 in the /etc/httpd/conf.d/phpmyadmin.conf and restart httpd again as mine is on a server. Working now.
    I'm like how it makes a folder for all you passwords in the Root directory
     
  13. Cory

    Cory Head Systems Administrator
    Administrator

    Joined:
    Jul 25, 2013
    Messages:
    54
    Likes Received:
    23
    Best Answers:
    0
    Did you do this on a clean VPS? If so, this doesn't add any entries for apache, and you don't need them.

    This has been tested and installed on production servers few hundred times. :p Works very well.
     
  14. ChrisC

    ChrisC Forum Moderator
    Moderator

    Joined:
    Jul 7, 2015
    Messages:
    2,490
    Likes Received:
    276
    Best Answers:
    5
    Its all good Cory, Its not a worry it on a Vps that i play around on I reinstalled a new Centos7. It only took me 5mins to find out happen to why the phpmyadmin website didn't show add i fixed that up. -Image :p.

    Great work with the auto-Install, works fantastically! Would you like me to add it to the tutorial as a Recommended step?
     
  15. Cory

    Cory Head Systems Administrator
    Administrator

    Joined:
    Jul 25, 2013
    Messages:
    54
    Likes Received:
    23
    Best Answers:
    0
    That's fine. :p

    I'm always adding new things. I recently also installed McMyAdmin for someone, and make an auto installer for that one too. Then I'd have to move all my similar stuff to functions.sh file, and update only that file when they're changes, and mostly, I can leave Multicraft/McMyAdmin untouched. :p
    I might change the repository, and I'll keep you posted. )
     
    • Like Like x 1
  16. ChrisC

    ChrisC Forum Moderator
    Moderator

    Joined:
    Jul 7, 2015
    Messages:
    2,490
    Likes Received:
    276
    Best Answers:
    5
    @Cory Would you know where the Php.ini be located in your setup for Centos7? I have added to phpinfo page to the www and its showing

    Configuration File (php.ini) Path = /etc
    Loaded Configuration File = (none)

    but when in do nano /etc/php.ini its empty.
     
  17. Cory

    Cory Head Systems Administrator
    Administrator

    Joined:
    Jul 25, 2013
    Messages:
    54
    Likes Received:
    23
    Best Answers:
    0
    Not off hand I do not. The script runs:
    Code:
    php -r "echo php_ini_loaded_file();
    This will get the php.ini file, path and all, removes the old /etc/PHP.ini and then symlinks it.

    I suppose the problem by looking at the script if the command gets only /etc/ and symlinks that, and then the php.ini would be empty. Sigh

    :(

    Might have to do a file check or something and then read the file and if it passes. Ignore symlink. If not, either provide a php.ini or find paths of the productions files.

    Code:
    yum -y install mlocate
    updatedb
    locate php.ini
    This will find a php.ini file for you can:

    Code:
    ln -s PATH /etc/php.ini
     
    • Like Like x 1
  18. ChrisC

    ChrisC Forum Moderator
    Moderator

    Joined:
    Jul 7, 2015
    Messages:
    2,490
    Likes Received:
    276
    Best Answers:
    5
    awsome! It found one in /usr/share/doc/php56w-common-5.6.29/.
    I was able to make a copy with

    Then renamed it to php.ini with
    Its now found the php.ini.
    Code:
    Server API =Apache 2.0 Handler
    Virtual Directory Support = disabled
    Configuration File (php.ini) Path =/etc
    Loaded Configuration File =/etc/php.ini
    Scan this dir for additional .ini files = /etc/php.d
    Make to changes tp php so i can upload more then the default on net2ftp.
    [​IMG]
     
  19. Cory

    Cory Head Systems Administrator
    Administrator

    Joined:
    Jul 25, 2013
    Messages:
    54
    Likes Received:
    23
    Best Answers:
    0
    Yep, that's the sole purpose of this. :)

    Code:
    # php.ini Auto-Detector
    PHP="$(php -r "echo php_ini_loaded_file();")"
    rm -fv /etc/php.ini
    ln -s ${PHP} /etc/php.ini
    
    # Modify php.ini Settings
    sed -i 's/upload_max_filesize = \(.*\)/\Eupload_max_filesize = 100M/g' /etc/php.ini
    sed -i 's/post_max_size = \(.*\)/\Epost_max_size = 100M/g' /etc/php.ini
    sed -i 's/max_execution_time = \(.*\)/\Emax_execution_time = 300/g' /etc/php.ini
    sed -i 's/max_input_time = \(.*\)/\Emax_input_time = 600/g' /etc/php.ini
    • Grabs php.ini file
    • Removes old php.ini file
    • Symlinks file to /etc/php.ini to avoid having to do more checks or more than one php.ini file.
    • The sed basically finds those things you want to change and increase the values automatically. :)
    There is an error likely, I'll probably find some default paths to copy from.
     
    • Like Like x 1
  20. jacksharkben

    jacksharkben Well-Known Member

    Joined:
    Mar 23, 2015
    Messages:
    1,770
    Likes Received:
    134
    Best Answers:
    1
    *Uses Google translate to translate this in English*
    Ooooohhhhh
     
    • Funny Funny x 1

Share This Page